Minimum system requirements

Loan application instructions for the 2016/2017 program year (for classes starting between Aug 1 2016 and July 31 2017)


Supported devices and browsers

To complete StudentAid BC online applications and appendices, your system must meet the following minimum requirements:

Operating System Browser Version Adobe Reader Version
Windows 7, Windows Vista Internet Explorer 11+ Adobe Reader 10.0+
Windows 7, Windows Vista Firefox 29+ Adobe Reader 10.0+ (to use PDF version)
Windows 7, Windows Vista Google Chrome 33+ Adobe Reader 10.0+ (to use PDF version)
OS X Yosemite, OS X Mavericks Safari 7+ Adobe Reader 10.0+ (to use PDF version)
iOS 8 on iPad 4th Safari Not required

Troubleshooting

If you experience issues with online applications or appendices, please try the following:

Internet Explorer 9+

  1. 1 Ensure you have Adobe Reader 10.0+ installed on your computer.
  2. 2 Click the button labeled either HTML or PDF at the top of an open form to switch between versions.
  3. 3 If switching versions of the form does not fix the issue you are having, please try a different browser from the supported list above.

Chrome 33+

  1. 1 Ensure you have Adobe Reader 10.0+ installed on your computer.
  2. 2 Choose to make Adobe Reader the default PDF viewer in Chrome.
  3. 3 Click the button labeled either HTML or PDF at the top of an open form to switch between versions.
  4. 4 If switching versions of the form does not fix the issue you are having, please try a different browser from the supported list above.

Safari 7+

  1. 1 Ensure you have Adobe Reader 10.0+ installed on your computer.
  2. 2 Choose to make Adobe Reader the default PDF viewer in Safari.
  3. 3 Click the button labeled either HTML or PDF at the top of an open form to switch between versions.
  4. 4 If switching versions of the form does not fix the issue you are having, please try a different browser from the supported list above.

Firefox 29+

  1. 1 Ensure you have Adobe Reader 10.0+ installed on your computer.
  2. 2 Choose to make Adobe Reader the default PDF viewer in Firefox.
  3. 3 Click the button labeled either HTML or PDF at the top of an open form to switch between versions.
  4. 4 If switching versions of the form does not fix the issue you are having, please try a different browser from the supported list above.

Safari on iPad

  1. 1 Please try a different browser from the supported list above.
If you have Adobe Reader 10.0+ installed and you are still having troubles with the PDF version, please check to see if you have Adobe Acrobat installed.
Contact Us
Toll-free Canada/US
1-800-561-1818
Outside North America
+ 1-250-387-6100